#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)page(\/)*([0-9\/])*"
Local $sString = "themen/mein-oberfranken/sanfter-tourismus/page" & @CRLF & _
"themen/mein-oberfranken/sanfter-tourismus/page/2" & @CRLF & _
"themen/mein-oberfranken/sanfter-tourismus/page/465" & @CRLF & _
"themen/mein-oberfranken/sanfter-tourismus/page/465/" & @CRLF & _
"themen/mein-oberfranken/sanfter-tourismus/page/" & @CRLF & _
"themen/mein-oberfranken/sanfter-tourismus/paGe/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")