using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"page(\/)*([0-9\/])*";
string input = @"themen/mein-oberfranken/sanfter-tourismus/page
themen/mein-oberfranken/sanfter-tourismus/page/2
themen/mein-oberfranken/sanfter-tourismus/page/465
themen/mein-oberfranken/sanfter-tourismus/page/465/
themen/mein-oberfranken/sanfter-tourismus/page/
themen/mein-oberfranken/sanfter-tourismus/paGe/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}