$re = '/^\d{2}$/m';
$str = '00
11
12
32
321
3
32a
a32
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);