const regex = /(?m)^[^\r\n,]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[^\\r\\n,]+', 'gm')
const str = `Brighton, United Kingdom
Singapore
Austin, TX, USA
San Francisco, CA, USA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}