#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{5})[-. ](\d{6})"
Local $sString = "something 01234 567890 around" & @CRLF & _
"aaa 01111-222111 bbbb" & @CRLF & _
"cccc 09876.543210 ddd" & @CRLF & _
""
Local $sSubst = "(one:\1) (two:\2) (three:3)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)