use strict;
my $str = 'something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
';
my $regex = qr/(\d{5})[-. ](\d{6})/mp;
my $subst = '(one:\\1) (two:\\2) (three:3)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";