// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{5})[-. ](\d{6})").unwrap();
let string = "something 01234 567890 around
aaa 01111-222111 bbbb
cccc 09876.543210 ddd
";
let substitution = "(one:\\1) (two:\\2) (three:3)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}