# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=Center X= )\d+(?= , )|(?<=Center Y= )\d+(?=,))"
test_str = ("^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^@DICM^B^@^@^@UL^D^@M-<^@^@^@^B^@^A^@OB^@^@^B^@^@^@^@^A^B^@^B^@UI^ ^^@1.2.840.10008.5.1.4.1.1.88.11^@^B^@^C^@UI,^@2.25.1394455567981633947292924600 3593050180^@^B^@^P^@UI^T^@1.2.840.10008.1.2.1^@^B^@^R^@UI^^^@1.2.826.0.1.3680043 .8.165.100^@^B^@^S^@SH\n"
"^@AK_STR_4_0^H^@^E^@CS\n"
"^@ISO_IR 192^H^@^R^@DA^H^@20221130^H^@^S^@TM\n"
"^@093512.236^H^@^T^@UI^N^@1.2.3.4.5.6.7^@^H^@^V^@UI^^^@1.2.840.10008.5.1.4.1.1.8 8.11^@^H^@^X^@UI,^@2.25.13944555679816339472929246003593050180^@^H^@ ^@DA^H^@202 21130^H^@#^@DA^H^@20221130^H^@0^@TM\n"
"^@092002.000^H^@3^@TM\n"
"^@093512.236^H^@P^@SH^H^@1835797 ^H^@`^@CS^B^@SR^H^@p^@LO^D^@Agfa^H^@M-^P^@PN^@^ @^H^@^Q^QSQ^@^@^@^@^@^@^P^@^P^@PN^N^P^@ ^@LO^L^@780222402136^P^@ 0^@DA^H^@19780222^P^@@^@CS^B^@F ^X^@^B^PUI^P^@1.2.3.4.5.6.7.20 ^@^M^@UI*^@1.2.82 6.0.1.3680043.8.165.100703.11836029^@ ^@^N^@UI,^@2.25.96426502300340166287633794 410492720461^@ ^@^P^@SH^H^@1835797 ^@Laterality^Q^@IS^B^@1 ^@^S^@IS^B^@1 @^@@M- CS\n"
"^@CONTAINER @^@CM- SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@^@^ASH^ F^@121144^H^@^B^ASH^D^@DCM ^H^@^D^ALO^P^@AKGUN BDT ReportM-~M-^?^MM-`^@^@^@^@M-~ M-^?M-]M-`^@^@^@^@@^@PM- CS^H^@SEPARATE@^@rM-#SQ^@^@^@^@^@^@@^@M-^QM-$CS^H^@PART IAL @^@M-^SM-$CS\n"
"^@UNVERIFIED@^@0M-'SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?@^@^PM- CS^ H^@CONTAINS@^@@M- CS^D^@TEXT@^@CM- SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^ ?M-^?^H^@^@^ASH^F^@121070^H^@^B^ASH^D^@DCM ^H^@^D^ALO^H^@FindingsM-~M-^?^MM-`^@^ @^@^@M-~M-^?M-]M-`^@^@^@^@@^@`M-!UT^@^@V^@^@^@Abnormal finding 1: Center X= 3711 , Center Y= 1919, Possibility= %74, Type= Benign MC\n"
"M-~M-^?^MM-`^@^@^@^@M-~M-^?^@M-`M-^?M-^?M-^?M-^?@^@^PM- CS^H^@CONTAINS@^@@M- CS^ D^@TEXT@^@CM- SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@^@^ASH^F^@12 1077^H^@^B^ASH^D^@DCM ^H^@^D^ALO\n"
"^@ConclusionM-~M-^?^MM-`^@^@^@^@M-~M-^?M-]M-`^@^@^@^@@^@`M-!UT^@^@^B^@^@^@- M-~M -^?^MM-`^@^@^@^@M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@M-^Y^QSQ^@^@M-^?M-^?M-^?M-^?M-~M -^?^@M-`M-^?M-^?M-^?M-^?^H^@P^QUI^\\^@1.2.840.10008.5.1.4.1.1.1.2^@^H^@U^QUI:^@1. 3.51.0.7.1467808936.33695.24902.40691.22053.24371.51322^@^H^@M-^Y^QSQ^@^@M-^?M-^ ?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@P^QUI^\\^@1.2.840.10008.5.1.4.1.1.11.1^H ^@U^QUI,^@2.25.253464016771080552631556563039538460246M-~M-^?^MM-`^@^@^@^@M-~M-^ ?M-]M-`^@^@^@^@M-~M-^?^MM-`^@^@^@^@M-~M-^?M-]M-`^@^@^@^@@^@^PM- CS^H^@CONTAINS@^ @@M- CS^D^@TEXT@^@CM- SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@^@^A SH^F^@121322^H^@^B^ASH^D^@DCM ^H^@^D^ALO^@^@M-~M-^?^MM-`^@^@^@^@M-~M-^?M-]M-`^@^ @^@^@M-~M-^?^MM-`^@^@^@^@M-~M-^?^@M-`M-^?M-^?M-^?M-^?@^@^PM- CS^H^@CONTAINS@^@@M - CS^D^@TEXT@^@CM- SQ^@^@M-^?M-^?M-^?M-^?M-~M-^?^@M-`M-^?M-^?M-^?M-^?^H^@^@^ASH^ F^@111027^H^@^B^ASH^D^@DCM ^H^@^D^ALO^P^@Image LateralityM-~M-^?^MM-`^@^@^@^@M-~ M-^?M-]M-`^@^@^@^@@^@`M-!UT^@^@^B^@^@^@R M-~M-^?^MM-`^@^@^@^@M-~M-^?M-]M-`^@^@^@")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.