$re = '/([a-zA-Z0-9]\w*)@/m';
$str = 'xyz123@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);