re = /[^@]{0,1}(@[a-zA-z\d]+)/m
str = '@test1 стоп, не так все
@test1 не знаю даже @test1 тест@test1привет @@test1р
Привет, ребят @test2 как дела? @test1 @test2@test1
@test1п'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end