import Foundation
let pattern = #"^.*\\bin\\.*\\.*[Tt]ests\.dll$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\release\TestProject.API.Manager.tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\release\TestProject.API.Manager.unittests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\SomeProject.dll
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)