using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!\.) )\b[a-z]\w+";
string input = @"var touchHandler = function(e)...
var touch = event.hasOwnProperty...
event.changedTouches...
event.originalEvent.changedTouches...
var simulatedEvent = document.createEvent(...
simulatedEvent.initMouseEvent({ touchend: ""mouseup""})
touch.target.dispatchEvent(simulatedEvent);
event.preventDefault();
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}