const regex = /((?!\.) )\b[a-z]\w+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?!\\.) )\\b[a-z]\\w+', 'gi')
const str = `var touchHandler = function(e)...
var touch = event.hasOwnProperty...
event.changedTouches...
event.originalEvent.changedTouches...
var simulatedEvent = document.createEvent(...
simulatedEvent.initMouseEvent({ touchend: "mouseup"})
touch.target.dispatchEvent(simulatedEvent);
event.preventDefault();
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}