$re = '/((?!\.) )\b[a-z]\w+/i';
$str = 'var touchHandler = function(e)...
var touch = event.hasOwnProperty...
event.changedTouches...
event.originalEvent.changedTouches...
var simulatedEvent = document.createEvent(...
simulatedEvent.initMouseEvent({ touchend: "mouseup"})
touch.target.dispatchEvent(simulatedEvent);
event.preventDefault();
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);