$re = '/customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)/m';
$str = '<p class="Pa0" style="margin: 0in 0in 0pt;"><span class="A1"><span style="font-size: 10pt;">Giving this flyer to your class customers</span></span></p>
';
$subst = "<span style='color: red;'>class<span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;