import re
regex = re.compile(r"customers(?=(?:[^><]*<[^<>]*>)*[^><]*$)", flags=re.MULTILINE)
test_str = ("<p class=\"Pa0\" style=\"margin: 0in 0in 0pt;\"><span class=\"A1\"><span style=\"font-size: 10pt;\">Giving this flyer to your class customers</span></span></p>\n")
subst = "<span style='color: red;'>class<span>"
result = regex.sub(subst, test_str)
if result:
print(result)