#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}[,|-])*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}$"
Local $sString = "192.168.1.1,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24" & @CRLF & _
"192.168.1.1/32" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.1/32" & @CRLF & _
"192.168.1.1/12" & @CRLF & _
"192.168.1.1/24" & @CRLF & _
"192.168.1.1/24" & @CRLF & _
"192.168.1.1/0,192.168.1.1/0" & @CRLF & _
"10.0.0.0/24" & @CRLF & _
"172.16.0.1-172.16.0.255" & @CRLF & _
"192.168.1.1,10.0.0.1/24,172.16.0.1-172.16.0.10" & @CRLF & _
"64.33.232.212" & @CRLF & _
"64.33.232.210/24"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")