const regex = new RegExp('^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\/(?:3[0-2]|[12]*\\d)){0,1}[,|-])*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\\/(?:3[0-2]|[12]*\\d)){0,1}$', 'gm')
const str = `192.168.1.1,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24
192.168.1.1/32
192.168.1.1
192.168.1.1/32
192.168.1.1/12
192.168.1.1/24
192.168.1.1/24
192.168.1.1/0,192.168.1.1/0
10.0.0.0/24
172.16.0.1-172.16.0.255
192.168.1.1,10.0.0.1/24,172.16.0.1-172.16.0.10
64.33.232.212
64.33.232.210/24`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}