# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}[,|-])*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\/(?:3[0-2]|[12]*\d)){0,1}$"
test_str = ("192.168.1.1,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24\n"
"192.168.1.1/32\n"
"192.168.1.1\n"
"192.168.1.1/32\n"
"192.168.1.1/12\n"
"192.168.1.1/24\n"
"192.168.1.1/24\n"
"192.168.1.1/0,192.168.1.1/0\n"
"10.0.0.0/24\n"
"172.16.0.1-172.16.0.255\n"
"192.168.1.1,10.0.0.1/24,172.16.0.1-172.16.0.10\n"
"64.33.232.212\n"
"64.33.232.210/24")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.