using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*#\D)|(\d*#^)";
string input = @"""8617722824323#312|86259920#None17722825198#""
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}