import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b|_)ELLs?(?=\\b|_)";
final String string = "ELL\n"
+ "ELLs\n"
+ "The ELL\n"
+ "Which ELLs\n"
+ "ELLs or _ELLs\n"
+ "However I also get following outputs\n\n"
+ "Ellis Island\n"
+ "Bellis";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}