$re = '/<tag>(?=(?:(?!<\/?tag>).)*?<b>)(?=(?:(?!<\/?tag>).)*?\{1})(?:(?!<\/?tag>).)*<\/tag>/m';
$str = '<tag><b>{1}test</tag>
<tag><b>test</tag>
<tag><b>{1}test</tag><tag><b>test</tag>
<tag>{1}test</tag><tag><b>test</tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);