#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)"
Local $sString = "Examples: 0.9 mg, 9 mg, 9mg, 0.9mg" & @CRLF & _
"0.9mg is the approximate dosage " & @CRLF & _
"98 is not an acceptable number; it has no unit" & @CRLF & _
"9.4.4mg is not acceptable; it is formatted wrong" & @CRLF & _
"9.7kg is fine, but 9.7kgasdfghjkl is not"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")