use strict;
my $str = 'Examples: 0.9 mg, 9 mg, 9mg, 0.9mg
0.9mg is the approximate dosage
98 is not an acceptable number; it has no unit
9.4.4mg is not acceptable; it is formatted wrong
9.7kg is fine, but 9.7kgasdfghjkl is not';
my $regex = qr/(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}