re = /^(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)$/m
str = '// Accept ✅
127.0.0.1
192.168.1.1
192.168.1.255
255.255.255.255
0.0.0.0
// Reject ❌
033.33.33.33
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end