#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^[a-zA-Z#\s]+)\d+|\d+(?=[a-zA-Z#\s]+$)"
Local $sString = "abc 12345678" & @CRLF & _
"abc12345678abc" & @CRLF & _
"#12345678" & @CRLF & _
"12345678#" & @CRLF & _
"12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")