re = /(?<=^[a-zA-Z#\s]+)\d+|\d+(?=[a-zA-Z#\s]+$)/m
str = 'abc 12345678
abc12345678abc
#12345678
12345678#
12345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end