# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^..).(?=.{3})/*/gm;t' <<< "7108898787654351
7108-8987-8765-4351"