const regex = /(?<!^..).(?=.{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^..).(?=.{3})', 'gm')
const str = `7108898787654351
7108-8987-8765-4351`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);