use strict;
my $str = '7108898787654351
7108-8987-8765-4351';
my $regex = qr/(?<!^..).(?=.{3})/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";