re = /(?<!^..).(?=.{3})/m
str = '7108898787654351
7108-8987-8765-4351'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result