# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.zip\b[^,]*(*SKIP)(*F)|\s/%20/gm;t' <<< "http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
"