package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.zip\b[^,]*(*SKIP)(*F)|\s`)
var str = `http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
`
var substitution = "%20"
fmt.Println(re.ReplaceAllString(str, substitution))
}