use strict;
my $str = 'http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
';
my $regex = qr/\.zip\b[^,]*(*SKIP)(*F)|\s/mp;
my $subst = '%20';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";