// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.zip\b[^,]*(*SKIP)(*F)|\s").unwrap();
let string = "http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
";
let substitution = "%20";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}