const regex = /Pixel [36]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Pixel [36]$', 'gm')
const str = `Pixel 7 Pro
Pixel 7
Pixel 3
Pixel 3 XL
Pixel 6
Pixel 4
Pixel 5
Pixel 3a
Pixel 6 Pro
Pixel 6 Pro
Pixel 3
Pixel 3 XL
Pixel 3a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}