package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(3|4)[0-9]{8}$`)
var str = `376876768
046786988989877789787h`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}