package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/(\w+)\/(\w+)\/?(\w+)?$`)
var str = `/posts/10/398`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}