import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])[a-zA-Z0-9_]{3,}$";
final String string = "qwer1234\n"
+ "qweQWE123\n"
+ "123\n"
+ "qwe\n"
+ "eifajdjf2123^%*(1sfjijda2(\n"
+ "1qaz2wsx3edc\n"
+ "qweQWE\n"
+ "QWE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}