using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\.\/.*temp";
string substitution = @"url_id_page_";
string input = @"<p><img class=""m-4"" src=""../../../img/page/temp/dd2b0a2c5925e4f55da1992456eb9ef8.webp"" alt="" width=""295"" height=""360""></p>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}