#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\s*)#\s(.*)$"
Local $sString = "parent:" & @CRLF & _
" A:" & @CRLF & _
" name: foo" & @CRLF & _
" value: x.y.z # check=something" & @CRLF & _
" # value: "yay" # check=nothing" & @CRLF & _
"" & @CRLF & _
" B:" & @CRLF & _
" name: bar" & @CRLF & _
" value: p.q.r # check=something" & @CRLF & _
" # value: "yay" # check=nothing"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)