import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\s*)#\\s(.*)$";
final String string = "parent:\n"
+ " A:\n"
+ " name: foo\n"
+ " value: x.y.z # check=something\n"
+ " # value: \"yay\" # check=nothing\n\n"
+ " B:\n"
+ " name: bar\n"
+ " value: p.q.r # check=something\n"
+ " # value: \"yay\" # check=nothing";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}