import Foundation
let pattern = ##"(^\s*)#\s(.*)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
parent:
A:
name: foo
value: x.y.z # check=something
# value: "yay" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: "yay" # check=nothing
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)