package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(http|https):\/\/[a-zA-Z-]*\.{0,1}[a-zA-Z-]{3,}\.[a-z]{2,})\/channel\/([a-zA-Z0-9_]{3,})$`)
var str = `https://www.youtube.com/channel/UCAoMPWcQKA_9Af5YhWdrZgw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}