re = /^(?:\d{10})?(?:\+)?(?:(?:\d{11})?(?:\d\(\d{3}\))?(?:(?:\d{7})?(?:-\d{3}-\d{4})?))$/m
str = '+19999999999
+1(999)9999999
+1(999)-999-9999
9999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end