$re = '/^[A-Z][^\d]{10,30}\.$/m';
$str = 'This is a good string.
this, not so good.
I\'m an okay string.
um, 3 things wrong here!
I\'m. A. Good. String.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);