#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-(?:\d*[-.]){2}"
Local $sString = "Ice Cold Murders- Rocco Schiavone-1-5.ts" & @CRLF & _
"Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts" & @CRLF & _
"Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")