using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(?:\d*[-.]){2}";
string input = @"Ice Cold Murders- Rocco Schiavone-1-5.ts
Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts
Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}