import Foundation
let pattern = #"-(?:\d*[-.]){2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ice Cold Murders- Rocco Schiavone-1-5.ts
Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts
Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)