import Foundation
let pattern = #"\/((?<prefix>[^\s\/]+)\/)*(?<fileName>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.(here file name should be data.csv)
/home/data/var/log/ data.csv
2.It doesn't have space after log
/home/data/var/log/data.csv
3.It has space with after log but file extension is different.(here file name is (data2015067987.dat)
/home/data/var/log/ data2015067987.dat
/home/data/var/log/ 201608587data.csv
4.(here file name is data data2 data3)
/home/data/var/log/ data data2 data3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)